eclipse系列: Cannot change version of project facet Dynamic web的解决方法

问题描述
        用Eclipse创建Maven结构的web项目的时候选择了Artifact Id为maven-artchetype-webapp,由于这个catalog比较老,用的servlet还是2.3的,而一般现在都是用3.0,在Project Facets里面修改Dynamic web module为3.0的时候就会出现Cannot change version of project facet Dynamic web module to 3.0,如图:
解决这个问题的步骤如下:
1. 把Servlet改成3.0,打开项目的web.xml
<?xmlversion="1.0"encoding="UTF-8"?>
<web-appxmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns="http://java.sun.com/xml/ns/javaee"
    xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_3_0.xsd"
    id="schedule-console"version="3.0">
2. 修改项目的设置,在Navigator下打开项目.settings目录下的org.eclipse.jdt.core.prefs
把1.5改成1.8
eclipse.preferences.version=1
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
org.eclipse.jdt.core.compiler.compliance=1.8
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
org.eclipse.jdt.core.compiler.problem.forbiddenReference=warning
org.eclipse.jdt.core.compiler.source=1.8
 
 
3. 打开org.eclipse.wst.common.project.facet.core.xml 
把java改为1.8, 把jst.web改为3.0;
<?xmlversion="1.0"encoding="UTF-8"?>
<faceted-project>
  <fixedfacet="wst.jsdt.web"/>
  <installedfacet="jst.web"version="3.0"/>
  <installedfacet="wst.jsdt.web"version="1.0"/>
  <installedfacet="java"version="1.8"/>
</faceted-project>
OK,搞定了。