Android Studio首次使用问题解决

今天下了个Android Studio,准备换个平台,但是创建新的项目遇到点问题,网上也没有找到完整的解决方法,研究了一下发出来供大家参考 问题:找不到R文件 报错Error:Execution failed for task ':app:processDebugResources'. > com.android.ide.common.process.ProcessException: Failed to execute aapt 问题原因:compileSdkVersion高于buildToolsVersion,可以用高版本的build-tool去构建一个低版本的sdk工程,但是反过来就不行了 解决方法:1.更新Android-SDK Build-Tools 2.修改build.gradle中相应版本号 之后我的问题就解决了 可能对于很多人来说根本不是问题,但是既然我遇上了,也就有可能有朋友还会遇到相同问题,希望能提供参考   from:https://www.cnblogs.com/madzxr/p/6322504.html

js调app原生方法

// 定义 const ApiBridge = {     msgQueue: [],     callbackCache: [],     callbackId: 0,     processingMsg: false,     isReady: false,     isNotifyReady: false }; ApiBridge.callNative = function(clz, method, args, callback) {     var msgJson = {};     msgJson.clz = clz;     msgJson.method = method;     if (args != undefined)         msgJson.args = args;     return prompt(JSON.stringify(msgJson)); }; // 调用 setTimeout(() => {         this.$ApiBridge.callNative("KCApiTSLModule", "notifyF", {           action: 'closePage',           param: {}         });       }); 以上代码经测试不能很好的兼容ios,下面的代码可以:

 

Android Studio 关于Kotlin Gradle plugin version编译出错问题

Android编译出错:The Android Gradle plugin supports only Kotlin Gradle plugin version 1.2.51 and higher. Project ‘Test’ is using version 1.2.30. 打开build.gradle(Project) 修改buildscript中的ext.kotlin_version = ‘1.2.30’ 改成ext.kotlin_version = ‘1.2.51’ 最后点击Sync Now,重新编译就好了   from:https://blog.csdn.net/qq_34947048/article/details/85250198

解决"No toolchains found in the NDK toolchains folder for ABI with prefix: mips64el-linux-android"错误

今天安装了Android Studio 3.2,打开一个旧工程,编译提示"No toolchains found in the NDK toolchains folder for ABI with prefix: mips64el-linux-android" 网上也有解决办法,就是下载旧版的NDK,将其中的toolchain复制到新版的NDK中 但是感觉这种方式,不是解决的正道。 经过对新版NDK的研究,发现NDK的更新记录里有一段话 This version of the NDK is incompatible with the Android Gradle plugin version 3.0 or older. If you see an error like No toolchains found in the NDK toolchains folder for ABI with prefix: mips64el-linux-android, update your project file to [use plugin version 3.1 or newer]. You will also need to upgrade to Android Studio 3.1 or newer.   也就是说新版本的NDK与3.0及以前旧版的Android Gradle plugin插件不兼容 其实解决方法很简单,就是修改build.gradle中的红字部分,改为3.1以上版本即可

  from:https://blog.csdn.net/vocanicy/article/details/83004626

错误NDK is missing a "platforms" directory.

编译错误提示:Gradle sync failed: Could not run build action using Gradle distribution 'https://services.gradle.org/distributions/gradle-4.1-all.zip'. 点击Gradle Console NDK is missing a "platforms" directory. If you are using NDK, verify the ndk.dir is set to a valid NDK directory.  It is currently set to D:\AndroidStudioSDK\ndk-bundle. If you are not using NDK, unset the NDK variable from ANDROID_NDK_HOME or local.properties to remove this warning. 不言而喻,NDK缺少一个“platforms”目录。如果您正在使用NDK,请验证NDK。将dir设置为有效的NDK目录。目前它被设置为D: AndroidStudioSDK\ndk-bundle。如果不使用NDK,请从ANDROID_NDK_HOME或local中卸载NDK变量。属性删除此警告。 这个错误Google 的坑。目前只有兼容最新的NDK版本才能解决。 解决办法: 1.打开SDK Manager 2.勾选上NDK最新版本,安装成功后Apply 3.安装完成后重新build下项目搞定!   from:https://blog.csdn.net/github_36787585/article/details/82841129

更换安卓模拟器路径

修改系统变量 变量名:ANDROID_SDK_HOME 变量值:存放avd的路径,如:D:\AVD 在Android Studio中运行模拟器时,提示Error: Not enough disk space to run AVD '….'. Exiting。是说安装模拟的磁盘空间不足,导致无法运行模拟器。 Android Studio 安装之后,默认的模拟器会安装在C盘中,可以打开模拟器管理界面,右键查看(Show on disk)模拟器安装的目录。如下图: 我的模拟器安装路径为: C:\Users\Administrator\.android\avd, 其中的avd文件夹就是用来存放模拟器镜像文件的。   第一步:需要将Pixel_API_27.avd的文件夹移出C盘,放入空间足够的磁盘中。   第二步:就是要修改Pixel_API_27.ini(在此就称为模拟器配置文件吧,我也是新手不太懂)文件中模拟器的路径。 然后重新运行模拟器,没有问题应该可以运行起来。   from:https://www.cnblogs.com/wang2804355025/p/13155556.html

Weex自定义Module

面试之家只是为了学习和交流使用Weex,题库等内容不可用于商业项目 在Weex开发中,使用自定义Module的方式,来扩展Weex的能力,官方教程在这里,这里我以自定义分享模块来举例 第一步 先创建一个继承与NSObject的基类UM_WeexModule,然后引入头文件#import <WeexSDK.h>,并继承WXModuleProtocol协议。 第二步 实现方法并暴露给JS

  第三步 将方法抛出给JS

  第四步 初始化时注册到WeexSDK

  第五步 JS调用

  结语 本篇文章旨在分享如何通过自定义Module来扩展Weex的能力,由于最近在忙于找工作,所以写的不是很深入,等过段时间稳定之后,会在继续分享Weex实现原理,以及从注册方法到可以被JS调用中间的实现过程。 作者:GL_fire 链接:https://www.jianshu.com/p/37b884515125 来源:简书 著作权归作者所有。商业转载请联系作者获得授权,非商业转载请注明出处。

weex采坑之旅(三)Android SDK环境搭建

上一篇文章我们配置了jdk version,这一节就来配置Android SDK环境搭建 Android SDK是Android平台上进行软件开发所需要的开发包,这里我们通过安装Android Studio的方式来安装Android SDK,Android Studio 是Android开发的IDE(集成开发环境),至少是2.0 或者更新版本 同样打开如下连接,此官方网站容易被墙 https://developer.android.com/studio/index.html 如果打不开换下面的路径,此为 android sdk 中文网站,下载 Android Studio http://www.androiddevtools.cn/ 然后运行你们下载的Android Studio进行安装,全选,然后下一步 到此处后,路径可以修改,我就都安装在D盘了,而且还是在同一个目录下,建议大家按照我的来安装, 注意安装目录不能有中文 第一个安装目录修改为 D:\Android\AndroidStudio 第二个安装目录修改为 D:\Android\sdk 我的安装位置 然后一直下一步,去掉勾选,点击finish 然后打开刚才修改的安装路径 D:\Android\sdk,运行 SDK Manager.exe 勾选下面几个(23.0.2一定要下),然后点击 install packages 安装成功后就开始安装环境变量,同样是在用户环境变量中新建一个(因为我已配置好) 变量名: ANDROID_HOME 变量值: D:\Android\sdk 然后在修改用户环境变量 path,是添加两个 变量名: path 变量值: %ANDROID_HOME%\platform-tools %ANDROID_HOME%\tools 如果环境变量是如下图的小伙伴,则在变量值最后面加上 ;%ANDROID_HOME%\platform-tools;%ANDROID_HOME%\tools 同样最后我们来检测是否安装和配置好,输入cmd打开命令行工具 输入 adb 如果出现的结果跟下面的图一样,那么恭喜你环境已经搭建好了 weex的环境变量就这样配置成功了,那么就开始入坑之旅吧! from:https://blog.csdn.net/k491022087/article/details/72934862

webview调用ios或者安卓的方法(内嵌h5页面调用app原生方法)

1.配合使用调用app原生的方法(h5页面不需要回调和数据) 实例1

  实例2

  2.配合使用调用app原生的方法(h5页面需要回调和数据) // 从App获取UUID(手机唯一标识)

标红字段为调用的app端定义的方法名,需要app端定义方法配合   from:https://www.cnblogs.com/wendyAndJken/p/9318501.html

Unsupported Modules Detected: Compilation is not supported for following modules: app, KeyboardView.

打开AS时出现了Unsupported Modules Detected: Compilation is not supported for following modules: app, KeyboardView. Unfortunately you can’t have non-Gradle Java modules and Android-Gradle modules in one project的错误,解决步骤如下: (1)关闭as (2)删除.idea目录 (3)删除app/build目录 (4)重新打开as from:https://blog.csdn.net/qq_40600379/article/details/106485687

No cached version of com.android.tools.build:gradle:3.6.2 available for offlin 解决办法

忙了一早晨,就是因为这个错误提示!!!!No cached version of com.android.tools.build:gradle:3.6.2 available for offlin 先说我的android studio 版本号:3.6.2 在之前的版本当中Settings->Builder….bababa… >gradel> offline work有这么个选项,但是在最新的版本当中是没有这个选项的!!!我找了一早晨!! 好了废话不多说,正题,位置在哪里?在这里!!!   默认的状态是:       你只要取消选中就是offline work不启动,也就是离线模式不不启用!!如果在截图当中没有这个,那么这个界面就在view->window tool->gradle,只要你选择了就会在右则弹出来这个选项   from:https://www.cnblogs.com/flay/p/12641381.html

安卓解决:Could not resolve all artifacts for configuration ':classpath’;

前天电脑重装了系统,所有东西重新配置,打开项目编译后发现:Could not resolve all artifacts for configuration ':classpath';这是什么鬼,然后常规clean、rebuild、offline work、修改本地gradle…一番操作之后,依然没用。最后上google寻求帮助,成功解决了这个问题。真凶尚不明确,怀疑是网络问题,资源库加载不下来。 解决办法如下:在根目录的build文件里加上这两句镜像代码,重新编译解决

  from:https://blog.csdn.net/c18871189293/article/details/105681103